Client PO Warehouse Server Performance Degradation

Incident Report for Enfusion by CWAN Status

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 15:14 CDT

Investigating

We are currently investigating this issue.
Posted Jun 18, 2026 - 14:58 CDT
This incident affected: US - Enfusion Application.