Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 13, 2026 - 07:30 CDT
Scheduled
A scheduled extended maintenance window is planned for Saturday, June 13, 2026 from 7:30 AM to 1:00 PM ET (11:30 AM – 5:00 PM UTC | 7:30 PM – 1:00 AM HKT, June 14) to support a series of system and server upgrades.
The following services (Production / Public QA) will be unavailable during this extended maintenance: - Main Enfusion Application: unavailable - RESTful / WebSocket API Services: unavailable - Web / Mobile Services: unavailable - Data Warehouse / Data Analytics Services: unavailable - Managed Services Application Access: unavailable - Scheduled Job / File Transmissions: delays expected
The Production and Public QA environments are expected to be restored to a steady state by 1:00 PM ET | 5:00 PM UTC | 1:00 AM HKT (June 14).
Posted Jun 08, 2026 - 06:42 CDT
This scheduled maintenance affected: US - Enfusion Application and EU - Enfusion Application.